Request quote system out of order
Incident Report for Vasilis Skarleas Network
Resolved
The problem has been resolved
Posted Dec 05, 2021 - 14:19 EET
Identified
We identified the issue but the service will continue to be a available.
Posted Nov 26, 2021 - 08:34 EET
Investigating
There are no requests that we can get accepted. We are investigating the issue.
Posted Nov 25, 2021 - 14:26 EET